Mac OS X Terminal Commands

Here are some basic Apple Mac OS X Terminal commands that can be useful.

IP Configuration: ifconfig
Flush the DNS Cache: dscacheutil -flushcache


The tcsh command shell of Darwin (the open source core of OS X)
cd - Change directory
clear - Clear terminal screen
cp - copy one or more files to another location
dd - Data Dump; convert and copy a file
df - display free disk space
dig - DNS lookup
dirs - Display a list of remembered directories
diskutil - Disk Utilities - format, verify, repair disk partitions
dscl - Directory Services command line utility
exec - Execute a command
exit - Exit the terminal
find - Search for files that meet a certain criteria
fs_usage - Filesystem usage (process/pathname)
hostname - Print or set system name
info - Help info
install - Copy files and set attributes
kill - Stop a process from running
l - List files in long format
locate - Find files
login - log into the computer
logout - exit a login shell
ls - List information about files
mkdir - Create new folder
mv - Move or rename files or directories
net - Manage network resources
passwd - Modify a user password
pbcopy - Copy data to the clipboard
pico - Open a simple text editor
ping - Test network connection
pmset - Power Management settings
pwd - Print working directory
quota - Display disk usage and limits
rm - Remove files
rmdir - Remove folder
screencapture - Capture screen image to file or disk
shutdown - Shutdown or restart OS X
softwareupdate - System software update
su - Substitute user identity
sudo - Execute a command as another user
traceroute - Trace Route to host
uname - Print system information